0

Не устанавливается на Ubuntu 19.10

Vision 4 months ago updated by DmitryA 4 months ago 1

При попытке установить Joxi пакет в Ubuntu 19.10 получаю

Подготовка к распаковке joxi-amd64.deb …

Распаковывается joxi (3.0.13) …

dpkg: зависимости пакетов не позволяют настроить пакет joxi:

joxi зависит от libqt5xmlpatterns5, однако:

Пакет libqt5xmlpatterns5 не установлен.

joxi зависит от qtdeclarative5-qtquick2-plugin, однако:

Пакет qtdeclarative5-qtquick2-plugin не установлен.

joxi зависит от libappindicator1, однако:

Пакет libappindicator1 не установлен.

joxi зависит от libmcrypt4, однако:

Пакет libmcrypt4 не установлен.

joxi зависит от libcurl3, однако:

Пакет libcurl3 не установлен.

Проблема заключается в устаревших зависимостях, которые не включены в репозиторий пакетов для 19 Ubuntu.

Аналогичная проблема на Fedora 31. Не устанавливается, проблемы с зависимостями:

Error:
Problem: conflicting requests
- nothing provides qt5-qtquick1 needed by joxi-3.0.7-3.0.7.x86_64
- nothing provides libQt5Declarative.so.5()(64bit) needed by joxi-3.0.7-3.0.7.x86_64
(try to add '--skip-broken' to skip uninstallable packages)

Поиск файлов для решения зависимостей приводит только к ещё большему поиску других зависимостей.