+1

Установка на Linux

wiomka 9 months ago updated 9 months ago 1

Не удается удовлетворить зависимости так как они ссылаются на старые версии пакетов.

$ sudo dpkg -i joxi-amd64.deb
Выбор ранее не выбранного пакета joxi.
(Чтение базы данных … на данный момент установлено 271146 файлов и каталогов.)
Подготовка к распаковке joxi-amd64.deb …
Распаковывается joxi (3.0.13) …
dpkg: зависимости пакетов не позволяют настроить пакет joxi:
 joxi зависит от libqt5script5, однако:
  Пакет libqt5script5 не установлен.
 joxi зависит от libqt5xmlpatterns5, однако:
  Пакет libqt5xmlpatterns5 не установлен.
 joxi зависит от qtdeclarative5-qtquick2-plugin, однако:
  Пакет qtdeclarative5-qtquick2-plugin не установлен.
 joxi зависит от libmcrypt4, однако:
  Пакет libmcrypt4 не установлен.
 joxi зависит от libcurl3, однако:
  Пакет libcurl3 не установлен.

dpkg: ошибка при обработке пакета joxi (--install):
 проблемы зависимостей — оставляем не настроенным
Обрабатываются триггеры для desktop-file-utils (0.23+linuxmint5) …
Обрабатываются триггеры для gnome-menus (3.13.3-11ubuntu1.1) …
Обрабатываются триггеры для mime-support (3.60ubuntu1) …
При обработке следующих пакетов произошли ошибки:
 joxi

$ apt install libqt5script5 libqt5xmlpatterns5 qtdeclarative5-qtquick2-plugin libmcrypt4 libcurl3
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Вы можете запустить «apt --fix-broken install» для исправления этих ошибок.
Следующие пакеты имеют неудовлетворённые зависимости:
 libcurl3 : Конфликтует: libcurl4 но 7.58.0-2ubuntu3.8 должен быть установлен
 libcurl4 : Конфликтует: libcurl3 но 7.58.0-2ubuntu2 должен быть установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt --fix-broken install», не указывая имени пакета (или указав решение).
$ apt install --fix-broken
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Исправление зависимостей… Готово
Следующие пакеты устанавливались автоматически и больше не требуются:
  libconfuse-common libconfuse2
Для их удаления используйте «sudo apt autoremove».
Следующие пакеты будут УДАЛЕНЫ:
  joxi
Обновлено 0 пакетов, установлено 0 новых пакетов, для удаления отмечено 1 пакетов, и 475 пакетов не обновлено.
Установлено или удалено не до конца 1 пакетов.
После данной операции объём занятого дискового пространства уменьшится на 2 097 kB.
Хотите продолжить? [Д/н] y
(Чтение базы данных … на данный момент установлен 271151 файл и каталог.)
Удаляется joxi (3.0.13) …
Обрабатываются триггеры для mime-support (3.60ubuntu1) …
Обрабатываются триггеры для desktop-file-utils (0.23+linuxmint5) …
Обрабатываются триггеры для gnome-menus (3.13.3-11ubuntu1.1) …

DISTRIB_ID=LinuxMint
DISTRIB_RELEASE=19
DISTRIB_CODENAME=tara
DISTRIB_DESCRIPTION="Linux Mint 19 Tara"
NAME="Linux Mint"
VERSION="19 (Tara)"
ID=linuxmint
ID_LIKE=ubuntu
PRETTY_NAME="Linux Mint 19"
VERSION_ID="19"
HOME_URL="https://www.linuxmint.com/"
SUPPORT_URL="https://forums.ubuntu.com/"
BUG_REPORT_URL="http://linuxmint-troubleshooting-guide.readthedocs.io/en/latest/"
PRIVACY_POLICY_URL="https://www.linuxmint.com/"
VERSION_CODENAME=tara
UBUNTU_CODENAME=bionic