0
Under review

Установка на CentOS 7

stalbutylka 1 week ago • updated yesterday at 11:55 a.m. 6

Здравствуйте, не могу установить joxi на CentOS 7. Были сложности с зависимыми пакетами, но они должны были решиться, так как это все делал в ручном режиме, их было порядка 10, но сейчас остались только 2, вот вывод:

Загружены модули: fastestmirror, langpacks
Проверка joxi-net_x86_64-fr.rpm: joxi-3.0.7-3.0.7.x86_64
joxi-net_x86_64-fr.rpm отмечен для установки
Разрешение зависимостей
--> Проверка сценария
---> Пакет joxi.x86_64 0:3.0.7-3.0.7 помечен для установки
--> Обработка зависимостей: libstdc++.so.6(GLIBCXX_3.4.21)(64bit) пакета: joxi-3.0.7-3.0.7.x86_64
Loading mirror speeds from cached hostfile
* base: centos.colocall.net
* epel: mirrors.colocall.net
* extras: centos.colocall.net
* updates: centos.colocall.net
--> Обработка зависимостей: qtspell-qt5 пакета: joxi-3.0.7-3.0.7.x86_64
--> Проверка зависимостей окончена
Ошибка: Пакет: joxi-3.0.7-3.0.7.x86_64 (/joxi-net_x86_64-fr)
Необходимо: qtspell-qt5
Ошибка: Пакет: joxi-3.0.7-3.0.7.x86_64 (/joxi-net_x86_64-fr)
Необходимо: libstdc++.so.6(GLIBCXX_3.4.21)(64bit)
Вы можете попробовать --skip-broken чтобы обойти проблему
Вы можете попробовать запустить: rpm -Va --nofiles --nodigest

Возможно Вы сможете подсказать как справиться с этой проблемой?

Answer

Answer
Under review

Здравствуйте.

На данный момент имеются проблемы с совместимостью текущих версий Joxi и актуальных версий linux. Работаем над решением проблемы.

Answer
Under review

Здравствуйте.

На данный момент имеются проблемы с совместимостью текущих версий Joxi и актуальных версий linux. Работаем над решением проблемы.

Возможно есть более низкие версии joxi, которые устанавливаются на данную ОС? Так как я не гонюсь за новшествами - меня бы устроил такой вариант, но на Вашем сайте ссылка только на одну версию joxi, может Вы мне сможете предоставить ссылку на более старую версию? 

К сожалению, пока нет

На данный момент, к сожалению, нет доступной для скачивания более ранней версии Joxi.

Насколько я понимаю - эта проблема продолжается достаточно давно https://joxi.userecho.com/communities/1/topics/1597-centos-721511-zavisimosti возможно если сейчас это невозможно - Вы рассмотрите вариант оставлять старые версии для CentOS так как понятно, что это вина системы, а не Ваша, но дело в том, что при всем желании чтобы установить libstdk++ версии 6, а не версии 4,8 нужно очень постараться. У меня не получилось к сожалению, я очень привык к joxi и был бы доволен и хотел бы пользоваться старой версией. Похоже на время придется искать что-то похожее, но пожалуйста рассмотрите вариант с оставлением старой версии joxi специально для этой ОС, даже мудрить ничего не придется)