0
Under review

Добрый день! Не работает установка на OpenSuse

Никита Суворов 3 years ago updated by Команда Joxi (Команда Joxi) 3 years ago 4

> sudo zypper in Загрузки/joxi-net_x86_64-os.rpm
Загрузка данных о репозиториях...
Чтение установленных пакетов...
Разрешение зависимостей пакетов...



Проблема: ничто не предоставляет libcurl, необходимый для joxi-3.0.7-3.0.7.x86_64
Решение 1: не устанавливать joxi-3.0.7-3.0.7.x86_64
Решение 2: повредить joxi-3.0.7-3.0.7.x86_64, игнорируя некоторые из его зависимостей



Выберите по номеру одно из вышеуказанных решений или отмените [1/2/c] (c):

Under review

Добрый день, уточните пожалуйста версию OpenSuse. Так же проверьте в yast пакет libcurl

добрый день!
opensuse 42.2

libcurl4 - установлен

на 42.1 установилось, но с поломкой зависимости libcurl

Здравствуйте, столкнулся с той же проблемой:

> cat /etc/SuSE-release

openSUSE 42.1 (x86_64)
VERSION = 42.1
CODENAME = Malachite

# /etc/SuSE-release is deprecated and will be removed in the future, use /etc/os-release instead


Установил с нарушением зависимости от libcurl:

# rpm -i joxi-net_x86_64-os.rpm

error: Failed dependencies:
libcurl is needed by joxi-3.0.7-3.0.7.x86_64


# rpm -i --nodeps joxi-net_x86_64-os.rpm


при запуске вижу ошибку:

> joxi

QSqlQuery::value: not positioned on a valid record
QSqlQuery::value: not positioned on a valid record
QSqlQuery::value: not positioned on a valid record
libpng warning: iCCP: known incorrect sRGB profile
QSqlQuery::value: not positioned on a valid record
QSqlQuery::value: not positioned on a valid record
QSqlQuery::value: not positioned on a valid record
Cannot mix incompatible Qt library (version 0x50501) with this library (version 0x50500)
Аварийный останов

Здравствуйте


По всем вопросам с запуском под linux в этот тикет:

http://joxi.userecho.com/topics/2200-ustanovka-v-1610/