0
Answered

Пакет для debian

Денис Подлесный 5 years ago updated by Артём Арифулин 4 years ago 7
Можете предоставить пакет для Debian 7?
Answered
Добрый день. Попробуйте поставить пакет для Ubuntu 12
joxi: error while loading shared libraries: libQtOpenGL.so.4: cannot open shared object file: No such file or directory
apt-get install libqt4-opengl-dev. Решил проблему но теперь новая. 
joxi: /lib/i386-linux-gnu/i686/cmov/libc.so.6: version `GLIBC_2.15' not found (required by /usr/lib/joxi/libopencv_highgui.so.2.4)
libopencv-highgui2.3 - computer vision High-level GUI and Media I/O library
Данная либа стоит в системе и ее версия ниже. Как мне решиь данную проблему?
http://stackoverflow.com/questions/10863613/how-to-upgrade-glibc-from-version-2-13-to-2-15-on-debian

Проблема решена.

В /etc/apt/sources.list нужно добавить deb http://ftp.debian.org/debian sid main (Для Debian 7)
потом обновить пакеты.
apt-get -t sid install libc6-amd64 libc6-dev libc6-dbg

apt-get -t sid install libc6-amd64 libc6-dev libc6-dbg

Пакеты, имеющие неудовлетворённые зависимости:
libdbus-1-3 : Ломает: dbus (< 1.9.16-1~)
Ломает: dbus:i386 (< 1.9.16-1~)
ppp : Ломает: network-manager (< 0.9.8.8-7~) но 0.9.4.0-10 будет установлен
udev : Ломает: ifupdown (< 0.8.5~)
Ломает: ifupdown:i386 (< 0.8.5~)

Не ставится joxi

joxi зависит от libqt5core5a, однако:
Пакет libqt5core5a не установлен и т.п.