Your comments

Дело в том, что они используют библиотеки, которые просто выпилили из федоры, они уже давно были помечены как устаревшие...

Для fedora 26, до сих пор не исправили :(

rpm -i joxi-net_x86_64-fr.rpm
ошибка: Неудовлетворенные зависимости:
libQt5Declarative.so.5()(64bit) нужен для joxi-3.0.7-3.0.7.x86_64
qt5-qtquick1 нужен для joxi-3.0.7-3.0.7.x86_64