+15
Answered
Оливер Фрост 2 years ago • updated by Команда Joxi (Команда Joxi) 1 year ago 26

1. При попытке установить через встроенный пакетный менеджер Fedora:

"Sorry, this did not work. Installion of joxi nice screenshoter failed."


2. При попытке установки через консоль:

rpm -ivh joxi.x86_64.rpm

error: Failed dependencies:
libQt5Core5 is needed by joxi-3.0.3-3.0.3.x86_64
libQt5Declarative5 is needed by joxi-3.0.3-3.0.3.x86_64
libQt5Gui5 is needed by joxi-3.0.3-3.0.3.x86_64
libQt5Network5 is needed by joxi-3.0.3-3.0.3.x86_64
libQt5OpenGL5 is needed by joxi-3.0.3-3.0.3.x86_64
libQt5Script5 is needed by joxi-3.0.3-3.0.3.x86_64
libQt5Sql5 is needed by joxi-3.0.3-3.0.3.x86_64
libQt5Widgets5 is needed by joxi-3.0.3-3.0.3.x86_64
libQt5X11Extras.so.5()(64bit) is needed by joxi-3.0.3-3.0.3.x86_64
libQt5X11Extras5 is needed by joxi-3.0.3-3.0.3.x86_64
libQt5Xml5 is needed by joxi-3.0.3-3.0.3.x86_64
libQt5XmlPatterns5 is needed by joxi-3.0.3-3.0.3.x86_64
libappindicator.so.1()(64bit) is needed by joxi-3.0.3-3.0.3.x86_64


После выполнения команды:

sudo dnf install qt-devel qt-doc qt-creator

И попытки запустить установку по новой ничего не изменилось.




Вопрос: Где найти и как установить недостающие зависимости?


System info:

uname -a

Linux localhost.localdomain 4.3.3-301.fc23.x86_64 #1 SMP Fri Jan 15 14:03:17 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux


Answer

Answer

Здравствуйте.


Попробуйте последние сборки: http://joxi.ru/BLmGpVSRB88M2l?d=1

Under review

Здравствуйте. Постараемся вам помочь. Просьба подождать немного.

$ sudo dnf provides 'libQt5Core.so.5'
Проверка истечения последних метаданных произведена 2:05:44 назад на Fri Jan 29 09:13:40 2016.
qt5-qtbase-5.5.1-11.fc23.i686 : Qt5 - QtBase components
Источник: updates


qt5-qtbase-5.5.0-18.fc23.i686 : Qt5 - QtBase components
Источник: fedora


Похоже, или в пакете для joxi прописана зависимость 'libQt5Core5' вместо 'libQt5Core.so.5' или наоборот, в пакете qt5-qtbase убрали 'libQt5Core5' из секции provides.

Answer

Здравствуйте.


Попробуйте последние сборки: http://joxi.ru/BLmGpVSRB88M2l?d=1

Ничего не поменялось, libQt5Core5 всё ещё есть в секции requires пакета, и зависимости не удовлетворяются

$ sudo dnf install f31063ed44.rpm 
Проверка истечения последних метаданных произведена 2:15:59 назад на Fri Jan 29 09:13:40 2016.
Ошибка: nothing provides libQt5Core5 needed by joxi-3.0.3-3.0.3.x86_64

+2

[user@localhost Downloads]$ rpm -ivh e88ea19675.rpm

error: Failed dependencies:

libcurl.so.4(CURL_OPENSSL_3)(64bit) is needed by joxi-3.0.9-3.0.9.x86_64


[user@localhost Downloads]$ sudo dnf install libcurl.so.4

Last metadata expiration check performed 1:38:10 ago on Sat Jan 30 16:37:08 2016.Package libcurl-7.43.0-4.fc23.i686 is already installed, skipping.

Dependencies resolved.

Nothing to do.

Complete!


[user@localhost Downloads]$ sudo dnf install e88ea19675.rpm --allowerasing

Last metadata expiration check performed 1:41:31 ago on Sat Jan 30 16:37:08 2016.Error: nothing provides libcurl.so.4(CURL_OPENSSL_3)(64bit) needed by joxi-3.0.9-3.0.9.x86_64



+1

Прошу прощения за настойчивость. Хочу узнать есть ли какие-нибудь продвижения в этом вопросе? У вас на официальной странице загрузки все еще висит нерабочая версия программы.

Здравствуйте.


Да, пока бета. Пока правим по всем дистрибутивам Линукс. На следующей неделе будет.

+1

Спасибо за апдейт. Жду пока ваши ребята поправят последнюю зависимость в beta для Fedora, которую я упоминал выше.

Присоединяюсь. Давно уже жду, когда Joxi будет работать на Федоре

Пробовал. Те же проблемы с зависимостями, что описаны выше

ошибка: Неудовлетворенные зависимости:

        libQt5Core5 нужен для joxi-3.0.9-3.0.9.x86_64

        libQt5Declarative.so.5()(64bit) нужен для joxi-3.0.9-3.0.9.x86_64

        libQt5Declarative5 нужен для joxi-3.0.9-3.0.9.x86_64

        libQt5Gui5 нужен для joxi-3.0.9-3.0.9.x86_64

        libQt5Network5 нужен для joxi-3.0.9-3.0.9.x86_64

        libQt5OpenGL5 нужен для joxi-3.0.9-3.0.9.x86_64

        libQt5Script5 нужен для joxi-3.0.9-3.0.9.x86_64

        libQt5Sql5 нужен для joxi-3.0.9-3.0.9.x86_64

        libQt5Widgets5 нужен для joxi-3.0.9-3.0.9.x86_64

        libQt5X11Extras5 нужен для joxi-3.0.9-3.0.9.x86_64

        libQt5Xml5 нужен для joxi-3.0.9-3.0.9.x86_64

        libQt5XmlPatterns5 нужен для joxi-3.0.9-3.0.9.x86_64

        libappindicator нужен для joxi-3.0.9-3.0.9.x86_64

        libappindicator.so.1()(64bit) нужен для joxi-3.0.9-3.0.9.x86_64

        libcurl.so.4(CURL_OPENSSL_3)(64bit) нужен для joxi-3.0.9-3.0.9.x86_64

        libcurl4 нужен для joxi-3.0.9-3.0.9.x86_64

ошибка: Неудовлетворенные зависимости:

        libQt5Declarative.so.5()(64bit) нужен для joxi-3.0.9-3.0.9.x86_64

        libappindicator.so.1()(64bit) нужен для joxi-3.0.9-3.0.9.x86_64

        libcurl.so.4(CURL_OPENSSL_3)(64bit) нужен для joxi-3.0.9-3.0.9.x86_64

        qtspell-qt5 нужен для joxi-3.0.9-3.0.9.x86_64

Уточните пожалуйста, вы устанавливаете пакет

joxi-net_x86_64-fr

или

joxi-net_x86_64-os

?

joxi-net_x86_64-fr.rpm:

ошибка: Неудовлетворенные зависимости:

        libQt5Declarative.so.5()(64bit) нужен для joxi-3.0.9-3.0.9.x86_64

        libappindicator.so.1()(64bit) нужен для joxi-3.0.9-3.0.9.x86_64

        libcurl.so.4(CURL_OPENSSL_3)(64bit) нужен для joxi-3.0.9-3.0.9.x86_64

        qtspell-qt5 нужен для joxi-3.0.9-3.0.9.x86_64

joxi-net_x86_64-os.rpm

ошибка: Неудовлетворенные зависимости:

        libQt5Core5 нужен для joxi-3.0.9-3.0.9.x86_64

        libQt5Declarative.so.5()(64bit) нужен для joxi-3.0.9-3.0.9.x86_64

        libQt5Declarative5 нужен для joxi-3.0.9-3.0.9.x86_64

        libQt5Gui5 нужен для joxi-3.0.9-3.0.9.x86_64

        libQt5Network5 нужен для joxi-3.0.9-3.0.9.x86_64

        libQt5OpenGL5 нужен для joxi-3.0.9-3.0.9.x86_64

        libQt5Script5 нужен для joxi-3.0.9-3.0.9.x86_64

        libQt5Sql5 нужен для joxi-3.0.9-3.0.9.x86_64

        libQt5Widgets5 нужен для joxi-3.0.9-3.0.9.x86_64

        libQt5X11Extras5 нужен для joxi-3.0.9-3.0.9.x86_64

        libQt5Xml5 нужен для joxi-3.0.9-3.0.9.x86_64

        libQt5XmlPatterns5 нужен для joxi-3.0.9-3.0.9.x86_64

        libappindicator нужен для joxi-3.0.9-3.0.9.x86_64

        libappindicator.so.1()(64bit) нужен для joxi-3.0.9-3.0.9.x86_64

        libcurl.so.4(CURL_OPENSSL_3)(64bit) нужен для joxi-3.0.9-3.0.9.x86_64

        libcurl4 нужен для joxi-3.0.9-3.0.9.x86_64

Как я понимаю "fr" это для Fedora, а "os" для CentOS.


Пакет: joxi-net_x86_64-fr.rpm
MD5: 03f59b4afe67e16ecd4f1255c0556c2d

При установке:

[oliverfrost@localhost Desktop]$ sudo dnf install e88ea19675.rpm

Last metadata expiration check performed 0:24:35 ago on Mon Feb 8 18:32:42 2016.

Error: nothing provides libcurl.so.4(CURL_OPENSSL_3)(64bit) needed by joxi-3.0.9-3.0.9.x86_64(try to add '--allowerasing' to command line to replace conflicting packages)



Все зависимости, перечисенные Антоном, кроме одной, можно установить ручками. Единственная зависимость которая не находится после всего это libcurl.so.4(CURL_OPENSSL_3)



[oliverfrost@localhost Desktop]$ sudo dnf install libcurl.so.4

Last metadata expiration check performed 0:36:56 ago on Mon Feb 8 18:32:42 2016.Package libcurl-7.43.0-4.fc23.i686 is already installed, skipping.

Dependencies resolved.



Как я понимаю, нужно перевести пакет с использования libcurl.so.4 на libcurl-7.43.0-4.fc23.i686.





Попробуйте пожалуйста эти пакеты http://joxi.ru/48AnNXSq0xX9AO?d=1

Я попробовал. После установки зависимостей руками всё установилось. Большое спасибо )

Не смог только залогиниться через соцсети, пришлось пароль вводить. Но невелика беда, и так отлично ))

После переустановки системы, а заодно и Joxi смог залогиниться и через ВК, так что всё работает

Тоже подтверждаю успешную установку и работоспособность.
Спасибо. Ждем официального релиза. Думаю, данную тему уже можно закрыть.

Столкнулся с теми же проблемами на Fedora23, последний билд установился, программа работает, но скриншоты на сервер не загружает (панель редактирования тоже не появляется).

Просто выбор скриншота и всё.

Вконтакте починили буквально накануне.


Спасибо.