+3
Under review
f1rst-test 2 months ago • updated by Диман Иванов 1 month ago 3

ошибка: Неудовлетворенные зависимости:
libQt5Declarative.so.5()(64bit) нужен для joxi-3.0.7-3.0.7.x86_64
libQt5Multimedia.so.5()(64bit) нужен для joxi-3.0.7-3.0.7.x86_64
qt5-qtquick1 нужен для joxi-3.0.7-3.0.7.x86_64


Были другие, их удовлетворил

Answer

-1
Answer
Under review

Здравствуйте.


По какой причине не смогли удовлетворить и эти зависимости? Требуется qt новее, 5.4.1

-1
Answer
Under review

Здравствуйте.


По какой причине не смогли удовлетворить и эти зависимости? Требуется qt новее, 5.4.1

+1

Подтверждаю. На Fedora 26 та же ошибка. Судя по всему, она была еще год назад, и в бете её уже правили: 

https://joxi.userecho.com/topics/50-nevozmozhno-ustanovit-na-fedora-23-iz-za-failed-dependencies/



dnf install ./joxi-net_x86_64-fr.rpm 
Последняя проверка окончания срока действия метаданных: 0:12:18 назад, Чт 20 июл 2017 18:59:41.
Ошибка: 
 Проблема: conflicting requests
  - nothing provides libQt5Declarative.so.5()(64bit) needed by joxi-3.0.7-3.0.7.x86_64

------------------------------------------------------------------------------------------------------------------

uname -r

4.12.5-300.fc26.x86_64

------------------------------------------------------------------------------------------------------------------

dnf install joxi-net_x86_64-fr.rpm 
Last metadata expiration check: 1:27:40 ago on Thu 24 Aug 2017 01:36:27 PM MSK.
Error: 
 Problem: conflicting requests
  - nothing provides libQt5Declarative.so.5()(64bit) needed by joxi-3.0.7-3.0.7.x86_64

------------------------------------------------------------------------------------------------------------------

dnf list installed | grep qt5
adwaita-qt5.x86_64                      1.0-1.fc26              @anaconda       
qt5-qtbase.x86_64                       5.7.1-19.fc26           @updates        
qt5-qtbase-common.noarch                5.7.1-19.fc26           @updates        
qt5-qtbase-gui.x86_64                   5.7.1-19.fc26           @updates        
qt5-qtdeclarative.x86_64                5.7.1-8.fc26            @anaconda       
qt5-qtimageformats.x86_64               5.7.1-5.fc26            @fedora         
qt5-qtxmlpatterns.x86_64                5.7.1-5.fc26            @anaconda       

------------------------------------------------------------------------------------------------------------------


Что я делаю не так? Почему вы не можете указать зависимости в пакете?